diff options
author | Zachary DeVito <zdevito@fb.com> | 2018-12-11 16:11:09 -0800 |
---|---|---|
committer | Facebook Github Bot <facebook-github-bot@users.noreply.github.com> | 2018-12-11 16:54:08 -0800 |
commit | 92314c83fa8bd27638ece087a95f0505e960d326 (patch) | |
tree | b50e714e74e063a11aa6db07328a7efbc0aa0014 /setup.py | |
parent | 71e0cb505c7576bd674eb93c111f82acf4625f97 (diff) | |
download | pytorch-92314c83fa8bd27638ece087a95f0505e960d326.tar.gz pytorch-92314c83fa8bd27638ece087a95f0505e960d326.tar.bz2 pytorch-92314c83fa8bd27638ece087a95f0505e960d326.zip |
re-enable copy of python files, but be careful that the copy is only … (#14982)
Summary:
…done once
This allow no-op build to work correctly even when BUILD_CAFFE2_OPS is on.
Pull Request resolved: https://github.com/pytorch/pytorch/pull/14982
Differential Revision: D13413960
Pulled By: zdevito
fbshipit-source-id: 6e5412a8c375af8a47c76f548cdd31cff15f3853
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 13 |
1 files changed, 0 insertions, 13 deletions
@@ -425,18 +425,6 @@ def build_libs(libs): sys.exit(1) -# Copy Caffe2's Python proto files (generated during the build with the -# protobuf python compiler) from the build folder to the root folder -# cp root/build/caffe2/proto/proto.py root/caffe2/proto/proto.py -def copy_protos(): - report('setup.py::copy_protos()') - for src in glob.glob( - os.path.join(caffe2_build_dir, 'caffe2', 'proto', '*.py')): - dst = os.path.join( - cwd, os.path.relpath(src, caffe2_build_dir)) - shutil.copyfile(src, dst) - - # Build all dependent libraries class build_deps(PytorchCommand): def run(self): @@ -528,7 +516,6 @@ class develop(setuptools.command.develop.develop): self.run_command('create_version_file') setuptools.command.develop.develop.run(self) self.create_compile_commands() - copy_protos() def create_compile_commands(self): def load(filename): |