summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorZach DeVito <zdevito@fb.com>2017-12-01 14:19:05 -0800
committerAdam Paszke <adam.paszke@gmail.com>2017-12-03 04:49:41 +0100
commit710f6d6958a04d7f99735ed01543bb15f97b86cc (patch)
tree064af9d2b19e8191867d9dd8c51cff74817042d0 /setup.py
parente5906db3e993f8024b998181e951a9b02707733f (diff)
downloadpytorch-710f6d6958a04d7f99735ed01543bb15f97b86cc.tar.gz
pytorch-710f6d6958a04d7f99735ed01543bb15f97b86cc.tar.bz2
pytorch-710f6d6958a04d7f99735ed01543bb15f97b86cc.zip
Fix warnings and add alert to enable ninja when developing.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4f75bf085c..e0800afcbe 100644
--- a/setup.py
+++ b/setup.py
@@ -224,6 +224,10 @@ class develop(setuptools.command.develop.develop):
for entry in load(f)]
with open('compile_commands.json', 'w') as f:
json.dump(all_commands, f, indent=2)
+ if not WITH_NINJA:
+ print("WARNING: 'develop' is not building C++ code incrementally")
+ print("because ninja is not installed. Run this to enable it:")
+ print(" > pip install ninja")
def monkey_patch_THD_link_flags():