diff options
author | Zach DeVito <zdevito@fb.com> | 2017-12-01 14:19:05 -0800 |
---|---|---|
committer | Adam Paszke <adam.paszke@gmail.com> | 2017-12-03 04:49:41 +0100 |
commit | 710f6d6958a04d7f99735ed01543bb15f97b86cc (patch) | |
tree | 064af9d2b19e8191867d9dd8c51cff74817042d0 /setup.py | |
parent | e5906db3e993f8024b998181e951a9b02707733f (diff) | |
download | pytorch-710f6d6958a04d7f99735ed01543bb15f97b86cc.tar.gz pytorch-710f6d6958a04d7f99735ed01543bb15f97b86cc.tar.bz2 pytorch-710f6d6958a04d7f99735ed01543bb15f97b86cc.zip |
Fix warnings and add alert to enable ninja when developing.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -224,6 +224,10 @@ class develop(setuptools.command.develop.develop): for entry in load(f)] with open('compile_commands.json', 'w') as f: json.dump(all_commands, f, indent=2) + if not WITH_NINJA: + print("WARNING: 'develop' is not building C++ code incrementally") + print("because ninja is not installed. Run this to enable it:") + print(" > pip install ninja") def monkey_patch_THD_link_flags(): |