summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYangqing Jia <jiayq84@gmail.com>2018-02-24 00:02:18 -0800
committerGitHub <noreply@github.com>2018-02-24 00:02:18 -0800
commitff189b9023b05d40740cbaa4f897cb1e3a934e37 (patch)
treeeda8cc0bd4f21364ea5157aa98830a72ed4cc5b3 /CMakeLists.txt
parent07414d94d7e86d881a045717c0311bd41bd5ec3b (diff)
downloadpytorch-ff189b9023b05d40740cbaa4f897cb1e3a934e37.tar.gz
pytorch-ff189b9023b05d40740cbaa4f897cb1e3a934e37.tar.bz2
pytorch-ff189b9023b05d40740cbaa4f897cb1e3a934e37.zip
Update CMake min requirement to 3, and use interface library for cuda libs. (#2021)
* Try use CMake interface library to simplify some of the cuda libs. * Bump to cmake 3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae1475dda7..dde4304bd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
+cmake_minimum_required(VERSION 3.0 FATAL_ERROR)
#cmake_policy(SET CMP0022 NEW)
#cmake_policy(SET CMP0023 NEW)