summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYangqing Jia <jiayq84@gmail.com>2018-06-06 20:56:31 -0700
committerGitHub <noreply@github.com>2018-06-06 20:56:31 -0700
commitb401e6b03a4f42a3cff3cfd7c68dd7718c8f7de0 (patch)
treefe90242ada9156e242a6b906bae3249fcc3fb3f7 /CMakeLists.txt
parent8af88f3525e1908deb9ac181ebfb9f8eb49bcb46 (diff)
downloadpytorch-b401e6b03a4f42a3cff3cfd7c68dd7718c8f7de0.tar.gz
pytorch-b401e6b03a4f42a3cff3cfd7c68dd7718c8f7de0.tar.bz2
pytorch-b401e6b03a4f42a3cff3cfd7c68dd7718c8f7de0.zip
Allow optional build and installation of native test binaries (#8225)
* test finetuning * install off by default * Turn BUILD_TEST=ON for jenkins. * Turn on install_test in jenkins as well
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1488f6e50..e80f1b04fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,8 +57,11 @@ cmake_dependent_option(
CAFFE2_USE_MSVC_STATIC_RUNTIME "Using MSVC static runtime libraries" ON
"NOT BUILD_SHARED_LIBS" OFF)
cmake_dependent_option(
- BUILD_TEST "Build Caffe2 C++ test binaries (need gtest and gbenchmark)" ON
+ BUILD_TEST "Build Caffe2 C++ test binaries (need gtest and gbenchmark)" OFF
"BUILD_CAFFE2" OFF)
+cmake_dependent_option(
+ INSTALL_TEST "Install test binaries if BUILD_TEST is on" OFF
+ "BUILD_TEST" OFF)
option(USE_ACL "Use ARM Compute Library" OFF)
option(USE_ASAN "Use Address Sanitizer" OFF)
option(USE_ATEN "Use ATen" OFF)