summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPieter Noordhuis <pcnoordhuis@gmail.com>2017-12-21 09:13:31 -0800
committerFacebook Github Bot <facebook-github-bot@users.noreply.github.com>2017-12-21 09:17:26 -0800
commit46054ddb5c191d9d889e8c7519b209726dda0318 (patch)
tree8d0dc36001ce2c19166acbc4a884bc1516e78d8b /CMakeLists.txt
parentcf1878814f719a766cc990b35b79df503ca71cb4 (diff)
downloadpytorch-46054ddb5c191d9d889e8c7519b209726dda0318.tar.gz
pytorch-46054ddb5c191d9d889e8c7519b209726dda0318.tar.bz2
pytorch-46054ddb5c191d9d889e8c7519b209726dda0318.zip
Run MiscCheck.cmake earlier in CMake process
Summary: This means warnings and errors fire sooner rather than later. This requires a fix for an issue where CMAKE_REQUIRED_FLAGS propagates to some unrelated check, which then fails, because the Android compiler doesn't support -mavx2. Closes https://github.com/caffe2/caffe2/pull/1646 Differential Revision: D6620129 Pulled By: pietern fbshipit-source-id: 4d1185406ebee3a523d39811bca6783bee82c898
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11975ab3e1..36bdbee8ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,6 +56,9 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
enable_testing()
+# ---[ Misc checks to cope with various compiler modes
+include(cmake/MiscCheck.cmake)
+
# External projects
include(ExternalProject)
@@ -73,9 +76,6 @@ endif()
# ---[ Dependencies
include(cmake/Dependencies.cmake)
-# ---[ Misc checks to cope with various compiler modes
-include(cmake/MiscCheck.cmake)
-
# ---[ Whitelist file if whitelist is specified
include(cmake/Whitelist.cmake)