summaryrefslogtreecommitdiff
path: root/gi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gi/Makefile.am')
-rw-r--r--gi/Makefile.am30
1 files changed, 19 insertions, 11 deletions
diff --git a/gi/Makefile.am b/gi/Makefile.am
index c651c97..2fbb4ac 100644
--- a/gi/Makefile.am
+++ b/gi/Makefile.am
@@ -7,7 +7,7 @@ SUBDIRS = \
repository \
overrides
-INCLUDES = -I$(top_srcdir)/gobject
+INCLUDES = -I$(top_srcdir)/gobject -I$(top_srcdir)/glib
pygidir = $(pkgpyexecdir)/gi
pygi_PYTHON = \
@@ -22,7 +22,7 @@ _gi_la_CFLAGS = \
_gi_la_LDFLAGS = \
-module \
-avoid-version \
- -export-symbols-regex init_gi
+ -export-symbols-regex "init_gi|PyInit__gi"
_gi_la_LIBADD = \
$(GI_LIBS)
_gi_la_SOURCES = \
@@ -34,6 +34,8 @@ _gi_la_SOURCES = \
pygi-invoke.h \
pygi-foreign.c \
pygi-foreign.h \
+ pygi-foreign-gvariant.c \
+ pygi-foreign-gvariant.h \
pygi-struct.c \
pygi-struct.h \
pygi-argument.c \
@@ -48,6 +50,8 @@ _gi_la_SOURCES = \
pygi-callbacks.h \
pygi.h \
pygi-private.h \
+ pygi-property.c \
+ pygi-property.h \
pygobject-external.h \
gimodule.c
@@ -58,24 +62,28 @@ _gi_cairo_la_CFLAGS = \
_gi_cairo_la_LDFLAGS = \
-module \
-avoid-version \
- -export-symbols-regex init_gi_cairo
+ -export-symbols-regex "init_gi_cairo|PyInit__gi_cairo"
_gi_cairo_la_LIBADD = \
$(GI_LIBS) \
$(PYCAIRO_LIBS)
_gi_cairo_la_SOURCES = pygi-foreign-cairo.c
-pygi_LTLIBRARIES = _gi.la _gi_cairo.la
+
+pygi_LTLIBRARIES = _gi.la
+
+if ENABLE_CAIRO
+pygi_LTLIBRARIES += _gi_cairo.la
+endif
+
# This is to ensure we have a symlink to the .so in the
# build directory, which the Python interpreter can load
# directly without having to know how to parse .la files.
-_gi.so: _gi.la
- rm -f $@ && $(LN_S) .libs/$@ $@
-_gi_cairo.so: _gi_cairo.la
- rm -f $@ && $(LN_S) .libs/$@ $@
+.la.so:
+ test -L $@ || $(LN_S) .libs/$@ $@
-all-local: _gi.so _gi_cairo.so
-check-local: _gi.so _gi_cairo.so
+all-local: $(LTLIBRARIES:.la=.so)
+check-local: $(LTLIBRARIES:.la=.so)
clean-local:
- rm -f _gi.so _gi_cairo.so
+ rm -f $(LTLIBRARIES:.la=.so)