summaryrefslogtreecommitdiff
path: root/gi/Makefile.am
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2017-07-12 08:48:07 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2017-07-12 08:48:11 +0900
commit3b5dc6176476d5ed2313cd7185d985f47e225165 (patch)
treeaee8e1d1c516bf7528eceae708baecfe484baddc /gi/Makefile.am
parentd80fc1d31f28c6bcf9ea34b253e8765321616c3c (diff)
downloadpygobject2-3b5dc6176476d5ed2313cd7185d985f47e225165.tar.gz
pygobject2-3b5dc6176476d5ed2313cd7185d985f47e225165.tar.bz2
pygobject2-3b5dc6176476d5ed2313cd7185d985f47e225165.zip
Imported Upstream version 3.7.2
Change-Id: I6fbadd2c5d032a44b4b424160cdbd0f097320457 Signed-off-by: DongHun Kwak <dh0128.kwak@samsung.com>
Diffstat (limited to 'gi/Makefile.am')
-rw-r--r--gi/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/gi/Makefile.am b/gi/Makefile.am
index f99e45b..4d93133 100644
--- a/gi/Makefile.am
+++ b/gi/Makefile.am
@@ -42,10 +42,10 @@ _gi_la_SOURCES = \
pygi-info.h \
pygi-foreign.c \
pygi-foreign.h \
- pygi-foreign-gvariant.c \
- pygi-foreign-gvariant.h \
pygi-struct.c \
pygi-struct.h \
+ pygi-source.c \
+ pygi-source.h \
pygi-argument.c \
pygi-argument.h \
pygi-type.c \
@@ -56,8 +56,6 @@ _gi_la_SOURCES = \
pygi-closure.h \
pygi-ccallback.c \
pygi-ccallback.h \
- pygi-callbacks.c \
- pygi-callbacks.h \
pygi.h \
pygi-private.h \
pygi-property.c \
@@ -117,7 +115,7 @@ _gi_cairo_la_LDFLAGS = \
# build directory, which the Python interpreter can load
# directly without having to know how to parse .la files.
.la.so:
- $(LN_S) .libs/$@ $@ || true
+ $(LN_S) -f .libs/$@ $@
# if we build in a separate tree, we need to symlink the *.py files from the
# source tree; Python does not accept the extensions and modules in different