summaryrefslogtreecommitdiff
path: root/packaging/ppl.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/ppl.spec')
-rw-r--r--packaging/ppl.spec45
1 files changed, 26 insertions, 19 deletions
diff --git a/packaging/ppl.spec b/packaging/ppl.spec
index 2831aa048..6c89fc2de 100644
--- a/packaging/ppl.spec
+++ b/packaging/ppl.spec
@@ -4,15 +4,16 @@ Release: 0
License: GPL-3.0+
Summary: The Parma Polyhedra Library
Url: http://www.cs.unipr.it/ppl/
-Group: Development/Libraries/C and C++
+Group: Platform Development/Build
Source: ppl-%{version}.tar.bz2
Source1: baselibs.conf
-Source1001: ppl.manifest
+Source1001: ppl.manifest
BuildRequires: gcc-c++
BuildRequires: gmp-devel >= 4.1.3
+BuildRequires: fdupes
%description
-The Parma Polyhedra Library (PPL) is a library for the manipulation of
+"The Parma Polyhedra Library (PPL) is a library for the manipulation of
(not necessarily closed) convex polyhedra and other numerical
abstractions. The applications of convex polyhedra include program
analysis, optimized compilation, integer and combinatorial optimization
@@ -22,11 +23,11 @@ memory is the only limitation to the dimension of anything), written in
accordance to all the applicable standards, exception-safe, rather
efficient, thoroughly documented, and free software. This package
provides all what is necessary to run applications using the PPL
-through its C and C++ interfaces.
+through its C and C++ interfaces."
%package devel
Summary: Development tools for the Parma Polyhedra Library C and C++ interfaces
-Group: Development/Libraries/C and C++
+Group: Platform Development/Build
Requires: gmp-devel >= 4.1.3
Requires: libppl = %{version}
Requires: libppl_c = %{version}
@@ -38,29 +39,29 @@ interfaces.
%package devel-static
Summary: Static libraries for the Parma Polyhedra Library C and C++ interfaces
-Group: Development/Libraries/C and C++
+Group: Platform Development/Build
Requires: ppl-devel = %{version}
%description devel-static
-Static libraries for the Parma Polyhedra Library C and C++ interfaces.
+Static libraries for the Parma Polyhedra Library C and C++ interfaces files.
%package -n libppl
Summary: Shared library for the Parma Polyhedra Library
-Group: Development/Libraries/C and C++
+Group: Platform Development/Build
%description -n libppl
-Shared library for the Parma Polyhedra Library.
+Shared library for the Parma Polyhedra Library files.
%package -n libppl_c
Summary: Shared library for the Parma Polyhedra Library C bindings
-Group: Development/Libraries/C and C++
+Group: Platform Development/Build
%description -n libppl_c
-Shared library for the Parma Polyhedra Library C bindings.
+Shared library for the Parma Polyhedra Library C bindings files.
%package doc
Summary: Documentation for the Parma Polyhedra Library
-Group: Development/Libraries/C and C++
+Group: Platform Development/Build
BuildArch: noarch
%description doc
@@ -73,14 +74,16 @@ want to program with the PPL.
cp %{SOURCE1001} .
%build
-%configure --enable-shared --with-pic --disable-rpath \
- --disable-watchdog
+%configure --enable-shared \
+ --with-pic \
+ --disable-rpath \
+ --disable-watchdog
#sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
#sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
-make %{?_smp_mflags}
+%__make %{?_smp_mflags}
%install
-make DESTDIR=%{buildroot} INSTALL="install -p" install
+%__make DESTDIR=%{buildroot} INSTALL="install -p" install
# We don't build the binary, so delete its manpage
rm -f %{buildroot}%{_mandir}/man1/ppl_lpsol.1
# We don't build pwl
@@ -92,10 +95,13 @@ rm -f %{buildroot}%{_datadir}/doc/%{name}/TODO
rm -f %{buildroot}%{_datadir}/doc/%{name}/gpl.*
rm -f %{buildroot}%{_datadir}/doc/%{name}/fdl.ps.gz
rm -f %{buildroot}%{_datadir}/doc/%{name}/fdl.pdf
+rm -f %{buildroot}%{_datadir}/doc/%{name}/COPYING
rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-prolog-interface-%{version}*
rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-ocaml-interface-%{version}*
rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-java-interface-%{version}*
+%fdupes %{buildroot}
+
%post -n libppl -p /sbin/ldconfig
%postun -n libppl -p /sbin/ldconfig
@@ -109,14 +115,13 @@ rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-java-interface-%{version}*
%defattr(-,root,root,-)
%dir %{_datadir}/doc/%{name}
%doc %{_datadir}/doc/%{name}/BUGS
-%doc %{_datadir}/doc/%{name}/COPYING
+%license COPYING
%doc %{_datadir}/doc/%{name}/CREDITS
%doc %{_datadir}/doc/%{name}/NEWS
%doc %{_datadir}/doc/%{name}/README
%{_bindir}/ppl_lcdd
%{_bindir}/ppl_pips
-%{_mandir}/man1/ppl_lcdd.1.gz
-%{_mandir}/man1/ppl_pips.1.gz
+
%files -n libppl
%manifest %{name}.manifest
@@ -161,3 +166,5 @@ rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-java-interface-%{version}*
%doc %{_datadir}/doc/%{name}/ppl-user-c-interface-%{version}-html/
%doc %{_datadir}/doc/%{name}/ppl-user-%{version}.pdf
%doc %{_datadir}/doc/%{name}/ppl-user-c-interface-%{version}.pdf
+%{_mandir}/man1/ppl_lcdd.1.gz
+%{_mandir}/man1/ppl_pips.1.gz \ No newline at end of file