summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..63e9b3f
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,23 @@
+
+noinst_PROGRAMS = amrnb-dec$(EXEEXT) amrnb-enc$(EXEEXT) amrwb-dec$(EXEEXT) linkboth$(EXEEXT)
+
+EXTRA_DIST = Makefile.alt
+
+INCLUDES = -I$(top_srcdir)/amrnb -I$(top_srcdir)/amrwb
+
+CLEANFILES = out.amr out.wav
+
+amrnb_dec_LDADD = $(top_builddir)/amrnb/libopencore-amrnb.la
+amrnb_enc_LDADD = $(top_builddir)/amrnb/libopencore-amrnb.la
+amrnb_enc_LDFLAGS = -lm
+amrwb_dec_LDADD = $(top_builddir)/amrwb/libopencore-amrwb.la
+linkboth_LDFLAGS = -static
+linkboth_LDADD = $(top_builddir)/amrnb/libopencore-amrnb.la $(top_builddir)/amrwb/libopencore-amrwb.la
+
+amrnb_dec_SOURCES = amrnb-dec.cpp wav.cpp
+amrnb_enc_SOURCES = amrnb-enc.c
+amrwb_dec_SOURCES = amrwb-dec.cpp wav.cpp
+linkboth_SOURCES = linkboth.c
+
+noinst_HEADERS = wav.h
+