summaryrefslogtreecommitdiff
path: root/distfiles/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'distfiles/debian/rules')
-rwxr-xr-xdistfiles/debian/rules54
1 files changed, 54 insertions, 0 deletions
diff --git a/distfiles/debian/rules b/distfiles/debian/rules
new file mode 100755
index 0000000..af51936
--- /dev/null
+++ b/distfiles/debian/rules
@@ -0,0 +1,54 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ python setup.py build
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Installing package
+ mkdir -p $(CURDIR)/debian/mic $(CURDIR)/debian/mic/usr/bin $(CURDIR)/debian/mic/usr/share/man/man1
+ install -m644 doc/mic.1 $(CURDIR)/debian/mic/usr/share/man/man1
+ #make DESTDIR=$(CURDIR)/debian/mic installman
+ #make DESTDIR=$(CURDIR)/debian/micng installconf
+ #make DESTDIR=$(CURDIR)/debian/micng installsymlinks
+ python setup.py install --root=$(CURDIR)/debian/mic
+
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_install
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_pysupport
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-arch: build install
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install