summaryrefslogtreecommitdiff
path: root/src/gallium/winsys/kmsro/drm/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/winsys/kmsro/drm/meson.build')
-rw-r--r--src/gallium/winsys/kmsro/drm/meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/gallium/winsys/kmsro/drm/meson.build b/src/gallium/winsys/kmsro/drm/meson.build
new file mode 100644
index 00000000000..f157982d728
--- /dev/null
+++ b/src/gallium/winsys/kmsro/drm/meson.build
@@ -0,0 +1,36 @@
+# Copyright © 2017 Broadcom
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+libkmsrowinsys = static_library(
+ 'kmsrowinsys',
+ files('kmsro_drm_winsys.c'),
+ include_directories : [
+ inc_src, inc_include,
+ inc_gallium, inc_gallium_aux, inc_gallium_winsys,
+ ],
+ c_args : [c_vis_args],
+ dependencies: dep_libdrm,
+ link_with : libvc4winsys,
+)
+
+driver_kmsro = declare_dependency(
+ compile_args : '-DGALLIUM_KMSRO',
+ link_with : libkmsrowinsys,
+)