summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLone_Wolf <lone_wolf@klaas-de-kat.nl>2023-04-27 19:44:55 +0200
committerEric Engestrom <eric@engestrom.ch>2023-05-01 09:02:35 +0100
commit8dbb8a42da45f14374c035c0c99ca12f18c99614 (patch)
tree55e5d2119dd8360dbca6776800505076ee399307 /meson.build
parent731681db4b0db8c8441255d81dbd3fefc7e01de4 (diff)
downloadmesa-8dbb8a42da45f14374c035c0c99ca12f18c99614.tar.gz
mesa-8dbb8a42da45f14374c035c0c99ca12f18c99614.tar.bz2
mesa-8dbb8a42da45f14374c035c0c99ca12f18c99614.zip
clc: Add clangASTMatchers to fix static llvm build of microsoft-clc with LLVM 16+
Cc: mesa-stable Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/22741> (cherry picked from commit d09a7132d8162ffa14fdbf71feea2a19b0158097)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 305b34df794..b6749d42841 100644
--- a/meson.build
+++ b/meson.build
@@ -1758,6 +1758,9 @@ if with_clc
if dep_llvm.version().version_compare('>= 15.0')
clang_modules += 'clangSupport'
endif
+ if dep_llvm.version().version_compare('>= 16.0')
+ clang_modules += 'clangASTMatchers'
+ endif
dep_clang = []
foreach m : clang_modules