summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-09-06 15:39:07 +0100
committerEric Engestrom <eric.engestrom@intel.com>2018-09-06 17:16:58 +0100
commit6daba55aa19db1863ee294e5d9241c876a05dd1b (patch)
treee9207f8a1a3d35bca529dbae6754e74d94a27e60 /meson.build
parent2b98a023d92117172f9be2607b3cf5a080646491 (diff)
downloadmesa-6daba55aa19db1863ee294e5d9241c876a05dd1b.tar.gz
mesa-6daba55aa19db1863ee294e5d9241c876a05dd1b.tar.bz2
mesa-6daba55aa19db1863ee294e5d9241c876a05dd1b.zip
meson: drop unnecessary llvm version hacks
The current minimum meson version supported is 0.44.1, so we have met both the 0.43 and 0.44 requirement to not need these hacks anymore :) Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 0 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index f33c596e03f..909d46a7428 100644
--- a/meson.build
+++ b/meson.build
@@ -1205,10 +1205,6 @@ else
endif
if with_llvm
_llvm_version = dep_llvm.version().split('.')
- # Development versions of LLVM have an 'svn' or 'git' suffix, we don't want
- # that for our version checks.
- # svn suffixes are stripped by meson as of 0.43, and git suffixes are
- # strippped as of 0.44, but we support older meson versions.
# 3 digits versions in LLVM only started from 3.4.1 on
if dep_llvm.version().version_compare('>= 3.4.1')
@@ -1217,11 +1213,6 @@ if with_llvm
_llvm_patch = '0'
endif
- if _llvm_patch.endswith('svn')
- _llvm_patch = _llvm_patch.split('s')[0]
- elif _llvm_patch.contains('git')
- _llvm_patch = _llvm_patch.split('g')[0]
- endif
pre_args += [
'-DHAVE_LLVM=0x0@0@0@1@'.format(_llvm_version[0], _llvm_version[1]),
'-DMESA_LLVM_VERSION_PATCH=@0@'.format(_llvm_patch),