summaryrefslogtreecommitdiff
path: root/tests/exslt/date/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/exslt/date/Makefile.am')
-rw-r--r--tests/exslt/date/Makefile.am29
1 files changed, 14 insertions, 15 deletions
diff --git a/tests/exslt/date/Makefile.am b/tests/exslt/date/Makefile.am
index ec1b896b..515f5496 100644
--- a/tests/exslt/date/Makefile.am
+++ b/tests/exslt/date/Makefile.am
@@ -38,23 +38,22 @@ CLEANFILES = .memdump
test-current:
@(echo > .memdump)
- @echo \<doc/\> >current.xml
- @echo "#"
- @echo "# Inspect the following for correctness"
- @echo "#"
- @(for i in $(srcdir)/current.xsl ; do \
- name=`basename $$i .xsl` ; \
- if [ ! -f $(srcdir)/$$name.xml ] ; then continue ; fi ; \
- $(top_builddir)/xsltproc/xsltproc $(srcdir)/$$name.xsl $(srcdir)/$$name.xml;\
- grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true;\
- done)
- @rm -f current.xml
+ @(if [ -z "$$CONTINUOUS_INTEGRATION" ]; then \
+ echo \<doc/\> >current.xml ; \
+ echo "#" ; \
+ echo "# Inspect the following for correctness" ; \
+ echo "#" ; \
+ for i in $(srcdir)/current.xsl ; do \
+ name=`basename $$i .xsl` ; \
+ if [ ! -f $(srcdir)/$$name.xml ] ; then continue ; fi ; \
+ $(top_builddir)/xsltproc/xsltproc $(srcdir)/$$name.xsl $(srcdir)/$$name.xml;\
+ grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true;\
+ done ; \
+ rm -f current.xml ; \
+ fi)
-test-logall:
+test tests: $(top_builddir)/xsltproc/xsltproc test-current
@echo '## Running exslt date tests'
-
-test tests: $(top_builddir)/xsltproc/xsltproc test-logall test-current
- @echo '## Running exslt common tests'
@(echo > .memdump)
@(for i in $(srcdir)/*.xsl ; do \
name=`basename $$i .xsl` ; \