summaryrefslogtreecommitdiff
path: root/python/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python/tests/Makefile.am')
-rw-r--r--python/tests/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/python/tests/Makefile.am b/python/tests/Makefile.am
index f757774f..cb186745 100644
--- a/python/tests/Makefile.am
+++ b/python/tests/Makefile.am
@@ -19,10 +19,15 @@ CLEANFILES = *.pyc core
if WITH_PYTHON
tests: $(TESTSPY)
- -@(PYTHONPATH="`pwd`/..:`pwd`/../.libs:$(srcdir)/.."; \
- if test "x$(LIBXML_SRC)" != "x" ; then PYTHONPATH="$$PYTHONPATH:$(LIBXML_SRC)/python:$(LIBXML_SRC)/python/.libs"; fi; \
+ @(PYTHONPATH="`pwd`/..:`pwd`/../.libs:$(srcdir)/.."; \
+ if test "x$(LIBXML_SRC)" != "x" ; then \
+ PYTHONPATH="$$PYTHONPATH:$(LIBXML_SRC)/python:$(LIBXML_SRC)/python/.libs"; \
+ fi; \
export PYTHONPATH; \
- for test in $(TESTSPY) ; do echo "-- $$test" ; (cd $(srcdir) && $(PYTHON) $$test ); done)
+ for test in $(TESTSPY) ; do \
+ echo "-- $$test" ; \
+ (cd $(srcdir) && $(PYTHON) $$test ) || exit 1; \
+ done)
else
tests:
endif