summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 566945df..a69995a5 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -240,7 +240,9 @@ libxslt-api.xml libxslt-refs.xml EXSLT/libexslt-api.xml \
($(XSLTPROC) -o ../libxslt/libxslt.syms $(srcdir)/syms.xsl $(srcdir)/symbols.xml)
xsltproc.1: $(srcdir)/xsltproc.xml
- -@$(XSLTPROC) --nonet $(srcdir)/xsltproc.xml
+ -@(if [ -x $(XSLTPROC) ] ; then \
+ echo "Rebuilding the man pages from the xml" ; \
+ $(XSLTPROC) --nonet $(srcdir)/xsltproc.xml ; fi)
# Note that in the following, xmllint output is piped to xsltproc
search.php: $(srcdir)/api.xsl $(srcdir)/site.xsl $(srcdir)/search.templ \