summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index da9340ce..215cde22 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ SUBDIRS = \
libexslt \
xsltproc \
doc \
- python \
+ @PYTHON_SUBDIR@ \
tests
else
SUBDIRS = \
@@ -14,10 +14,12 @@ SUBDIRS = \
libexslt \
xsltproc \
doc \
- python \
+ @PYTHON_SUBDIR@ \
tests
endif
+DIST_SUBDIRS = libxslt libexslt xsltproc python doc tests breakpoint
+
confexecdir=$(libdir)
confexec_DATA = xsltConf.sh
@@ -51,7 +53,7 @@ dummy:
tests: dummy
@(cd tests ; $(MAKE) tests)
- @(cd python ; $(MAKE) tests)
+ @(if [ "@PYTHON_SUBDIR@" != "" ] ; then cd python ; $(MAKE) tests ; fi)
valgrind:
@echo '## Running the regression tests under Valgrind'