summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWilliam M. Brack <wbrack@src.gnome.org>2004-03-06 15:07:44 +0000
committerWilliam M. Brack <wbrack@src.gnome.org>2004-03-06 15:07:44 +0000
commitf11fd0945cbbead3b0e1a2c16c295ce2bdcecc73 (patch)
tree850fb4a825bd9a2fbd03a99a094f0815997e4309 /tests/Makefile.am
parent0e4e81ebb27b3c9537a33f0a05b9464aa5e92f79 (diff)
downloadlibxslt-f11fd0945cbbead3b0e1a2c16c295ce2bdcecc73.tar.gz
libxslt-f11fd0945cbbead3b0e1a2c16c295ce2bdcecc73.tar.bz2
libxslt-f11fd0945cbbead3b0e1a2c16c295ce2bdcecc73.zip
Major enhancement to "make tests". All but Python tests cleaned up to
* Makefile.am, tests/Makefile.am, tests/REC/Makefile.am, tests/REC1/Makefile.am, tests/REC2/Makefile.am, tests/XSLTMark/Makefile.am, tests/docbook/Makefile.am, tests/exslt/common/Makefile.am, tests/exslt/date/Makefile.am, tests/exslt/functions/Makefile.am, tests/exslt/math/Makefile.am, tests/exslt/sets/Makefile.am, tests/exslt/strings/Makefile.am, tests/extensions/Makefile.am, tests/general/Makefile.am, tests/keys/Makefile.am, tests/multiple/Makefile.am, tests/namespaces/Makefile.am, tests/numbers/Makefile.am, tests/reports/Makefile.am, test/xmlspec/Makefile.am, tests/general/bug-60.err, tests/docbook/result/html/gdp-handbook.err, tests/REC/test-2.5-1.err: Major enhancement to "make tests". All but Python tests cleaned up to produce minimum summary output if no problems. * tests/general/bug-145.xsl, tests/general/bug-145.err, tests/docs/Makefile.am, tests/docs/bug-145.xml: Added test case for bugzilla bug 135938
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a1589203..8fd4e8b5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,6 +5,11 @@ SUBDIRS=docs REC1 REC2 REC general namespaces keys numbers documents \
all:
+# Each subdirectory has it's own Makefile to cater for the unique
+# requirements of that subdirectory. In general, xsltproc will be
+# run on the *.xsl / *.xml file combinations, and the output of that
+# run will be compared with the "expected" output contained in *.out
+# and (if errors are expected) in *.err
test tests:
@(cur=`pwd` ; for dir in $(SUBDIRS) ; do cd $$dir ; $(MAKE) CHECKER='$(CHECKER)' tests ; cd $$cur ; done)