summaryrefslogtreecommitdiff
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2003-10-28 14:33:17 +0000
committerDaniel Veillard <veillard@src.gnome.org>2003-10-28 14:33:17 +0000
commitdb3d2b48e890e6f8ddc009fbd14f8a914edbbc71 (patch)
tree4a82888b4c9607929d3b8cf36580f21079777436 /python/Makefile.am
parentd09eebaf565feadf15e8db68eb764015f9923bf1 (diff)
downloadlibxslt-db3d2b48e890e6f8ddc009fbd14f8a914edbbc71.tar.gz
libxslt-db3d2b48e890e6f8ddc009fbd14f8a914edbbc71.tar.bz2
libxslt-db3d2b48e890e6f8ddc009fbd14f8a914edbbc71.zip
applied patch from Roumen Petrov for bug #124539 when building outside the
* configure.in python/Makefile.am python/tests/Makefile.am: applied patch from Roumen Petrov for bug #124539 when building outside the source directory * libxslt/xsltutils.c: fixed the way to grab the line number from the document, use the predefiend libxml2 API which mate it work with both 2.5.x and 2.6.x Daniel
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index b6ac5779..b13c4308 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -7,7 +7,8 @@ INCLUDES = \
-I$(PYTHON_INCLUDES) \
$(LIBXML_CFLAGS) \
-I$(top_srcdir)/libxslt \
- -I$(top_srcdir)
+ -I$(top_srcdir) \
+ -I../libexslt
DOCS_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)
# libxsltclass.txt is generated
@@ -46,7 +47,7 @@ install-data-local:
@INSTALL@ -m 0644 libxslt.py $(DESTDIR)$(pythondir)
$(mkinstalldirs) $(DESTDIR)$(DOCS_DIR)
@(for doc in $(DOCS) ; \
- do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
+ do @INSTALL@ -m 0644 $(srcdir)/$$doc $(DESTDIR)$(DOCS_DIR) ; done)
GENERATE = generator.py
API_DESC = $(top_srcdir)/doc/libxslt-api.xml $(srcdir)/libxslt-python-api.xml