summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2001-01-07 14:01:28 +0000
committerDaniel Veillard <veillard@src.gnome.org>2001-01-07 14:01:28 +0000
commit6f5e152012186758087a2eead15199e795f8e192 (patch)
tree36df1a9259ec43df426ee322bc5408d111e6eddd /Makefile.am
parent8a5bfd81e5b31731172e3cb21136f6ac517299c6 (diff)
downloadlibxslt-6f5e152012186758087a2eead15199e795f8e192.tar.gz
libxslt-6f5e152012186758087a2eead15199e795f8e192.tar.bz2
libxslt-6f5e152012186758087a2eead15199e795f8e192.zip
Initial revision
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..a34c42dd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+SUBDIRS = \
+ libxslt \
+ tests
+
+confexecdir=$(libdir)
+confexec_DATA = xsltConf.sh
+
+bin_SCRIPTS = xslt-config
+
+EXTRA_DIST = xsltConf.sh.in xslt-config.in
+
+
+## We create xsltConf.sh here and not from configure because we want
+## to get the paths expanded correctly. Macros like srcdir are given
+## the value NONE in configure if the user doesn't specify them (this
+## is an autoconf feature, not a bug).
+
+xsltConf.sh: xsltConf.sh.in Makefile
+## Use sed and then mv to avoid problems if the user interrupts.
+ sed -e 's?\@XSLT_LIBDIR\@?$(XSLT_LIBDIR)?g' \
+ -e 's?\@XSLT_INCLUDEDIR\@?$(XSLT_INCLUDEDIR)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
+ -e 's?\@XSLT_LIBS\@?$(XSLT_LIBS)?g' \
+ < $(srcdir)/xsltConf.sh.in > xsltConf.tmp \
+ && mv xsltConf.tmp xsltConf.sh
+
+
+
+