summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2018-07-17 17:21:02 +0200
committerJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2018-07-17 17:31:55 +0200
commit83a553a00966326bca29bcd3e06996a54fc1fc41 (patch)
treec4ba949c73ac5462b8c73f7051d00330b255c9b4 /meson.build
parenta3c907d3891bb275b9d2592d7a94d94020866b3c (diff)
downloadlibxkbcommon-83a553a00966326bca29bcd3e06996a54fc1fc41.tar.gz
libxkbcommon-83a553a00966326bca29bcd3e06996a54fc1fc41.tar.bz2
libxkbcommon-83a553a00966326bca29bcd3e06996a54fc1fc41.zip
meson: Fix xkbcommon-x11.pc Requires versioning
Old meson expects an array with one dependency per element. Providing a string containing multiple deps results in only the first dep getting its whitespace properly applied. As a result, the output was: Requires.private: xcb >= 1.10 xcb-xkb>=1.10 And downstream projects failed to find a package named 'xcb-xkb>=1.10'. Specifying an array of versioned deps results in correct output: Requires.private: xcb >= 1.10, xcb-xkb >= 1.10 Fixes #64. Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3935182..360958b 100644
--- a/meson.build
+++ b/meson.build
@@ -258,8 +258,8 @@ You can disable X11 support with -Denable-x11=false.''')
libraries: libxkbcommon_x11,
version: meson.project_version(),
description: 'XKB API common to servers and clients - X11 support',
- requires: 'xkbcommon',
- requires_private: 'xcb>=1.10 xcb-xkb>=1.10',
+ requires: ['xkbcommon'],
+ requires_private: ['xcb>=1.10', 'xcb-xkb>=1.10'],
)
endif