summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPierre Le Marre <dev@wismill.eu>2023-09-18 13:17:17 +0200
committerWismill <dev@wismill.eu>2023-09-18 16:07:09 +0200
commit26b1a07659f4fb8081190a24d9774fd74dcb1e95 (patch)
treec616d246191a33cd5520d9784416a0402167e57f /meson.build
parentc1b6c79abab77185fe52f4117c18377fe0e72a5d (diff)
downloadlibxkbcommon-26b1a07659f4fb8081190a24d9774fd74dcb1e95.tar.gz
libxkbcommon-26b1a07659f4fb8081190a24d9774fd74dcb1e95.tar.bz2
libxkbcommon-26b1a07659f4fb8081190a24d9774fd74dcb1e95.zip
Test: Use a xvfb wrapper for x11 test
The x11 test is currently silently skipped in CI, because it requires a running X server. Create a xvfb wrapper to run the test. We do not use `xvfb-run`, because it is a shell script and it causes valgrind to detect unrelated memory issues in the shell (dash, bash). Improve wrapper using a special ELF section TODO: The wrapper is intended to be used with the x11comp test as well.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6a79093..0769919 100644
--- a/meson.build
+++ b/meson.build
@@ -573,9 +573,11 @@ test_dep = declare_dependency(
link_with: libxkbcommon_test_internal,
)
if get_option('enable-x11')
- libxkbcommon_x11_internal = static_library(
+ libxkbcommon_x11_test_internal = static_library(
'xkbcommon-x11-internal',
libxkbcommon_x11_sources,
+ 'test/xvfb-wrapper.c',
+ 'test/xvfb-wrapper.h',
include_directories: include_directories('src', 'include'),
link_with: libxkbcommon_test_internal,
dependencies: [
@@ -584,7 +586,7 @@ if get_option('enable-x11')
],
)
x11_test_dep = declare_dependency(
- link_with: libxkbcommon_x11_internal,
+ link_with: libxkbcommon_x11_test_internal,
dependencies: [
test_dep,
xcb_dep,