summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPierre Le Marre <dev@wismill.eu>2023-09-18 12:17:11 +0200
committerWismill <dev@wismill.eu>2023-09-18 16:14:12 +0200
commit0e3e2d17302e99e68bdab3b5db0a1dcc835e5bee (patch)
tree1a7b8f3c380fe0b9437dbf39e06f414637bc071f /meson.build
parentb5079dc96dbc899d1acfb38a9aeb999b31a223ca (diff)
downloadlibxkbcommon-0e3e2d17302e99e68bdab3b5db0a1dcc835e5bee.tar.gz
libxkbcommon-0e3e2d17302e99e68bdab3b5db0a1dcc835e5bee.tar.bz2
libxkbcommon-0e3e2d17302e99e68bdab3b5db0a1dcc835e5bee.zip
interactive-evdev: add option to print modmaps
Add an option to print modmap and vmodmap of relevant keys, as well as virtual modifiers mapping to real modifier. This is useful for debugging. It uses private API, so we compile it separately in the fashion of `xkbcli-compile-keymap/compile-keymap`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 14 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7b941d0..0d6c8ce 100644
--- a/meson.build
+++ b/meson.build
@@ -416,10 +416,13 @@ man_pages = []
# Tools
build_tools = get_option('enable-tools') and cc.has_header_symbol('getopt.h', 'getopt_long', prefix: '#define _GNU_SOURCE')
if build_tools
- libxkbcommon_tools_internal = static_library(
- 'tools-internal',
+ libxkbcommon_tools_internal_sources = [
'tools/tools-common.h',
'tools/tools-common.c',
+ ]
+ libxkbcommon_tools_internal = static_library(
+ 'tools-internal',
+ libxkbcommon_tools_internal_sources,
dependencies: dep_libxkbcommon,
)
tools_dep = declare_dependency(
@@ -467,6 +470,15 @@ if build_tools
install_dir: dir_libexec)
configh_data.set10('HAVE_XKBCLI_INTERACTIVE_EVDEV', true)
install_man('tools/xkbcli-interactive-evdev.1')
+ # The same tool again, but with access to some private APIs.
+ executable('interactive-evdev',
+ 'tools/interactive-evdev.c',
+ libxkbcommon_sources,
+ libxkbcommon_tools_internal_sources,
+ dependencies: [tools_dep],
+ c_args: ['-DENABLE_PRIVATE_APIS'],
+ include_directories: [include_directories('src', 'include')],
+ install: false)
endif
if get_option('enable-x11')
x11_tools_dep = declare_dependency(