summaryrefslogtreecommitdiff
path: root/src/shaders/post_processing/gen7/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/shaders/post_processing/gen7/Makefile.am')
-rw-r--r--src/shaders/post_processing/gen7/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/shaders/post_processing/gen7/Makefile.am b/src/shaders/post_processing/gen7/Makefile.am
index 1ffc1cd..f4e2a8d 100644
--- a/src/shaders/post_processing/gen7/Makefile.am
+++ b/src/shaders/post_processing/gen7/Makefile.am
@@ -82,6 +82,7 @@ all-local: $(TARGETS)
SUFFIXES = .g7b .g7s .asm
+if HAVE_GEN4ASM
$(INTEL_PP_GEN7_ASM): $(INTEL_PP_ASM) $(INTEL_PP_G4A)
.asm.g7s:
$(AM_V_GEN)cpp $< > _pp0.$@; \
@@ -92,6 +93,7 @@ $(INTEL_PP_GEN7_ASM): $(INTEL_PP_ASM) $(INTEL_PP_G4A)
.g7s.g75b:
$(AM_V_GEN)$(GEN4ASM) -a -o $@ -g 7.5 $<
+endif
CLEANFILES = $(INTEL_PP_GEN7_ASM)