summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..425aa3b
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,29 @@
+if ENABLE_DOXYGEN_DOC
+
+all-local: doxygen.stamp
+
+doxygen.stamp: $(top_srcdir)/include/thai/*.h $(top_srcdir)/src/*/*.c
+ $(DOXYGEN)
+ touch doxygen.stamp
+
+install-data-local: install-html
+
+install-html:
+ $(INSTALL) -d $(DESTDIR)$(htmldocdir)
+ $(INSTALL_DATA) html/* $(DESTDIR)$(htmldocdir)
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(htmldocdir)
+
+clean-local:
+ rm -rf html
+ rm -f doxygen.stamp
+
+else
+
+install-data-local:
+uninstall-local:
+clean-local:
+
+endif
+