summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 06439b4..5bf3622 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,10 +16,12 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
-AM_CPPFLAGS = -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_builddir)/gl
+AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS) $(CODE_COVERAGE_CFLAGS)
+AM_CPPFLAGS = -I$(top_builddir)/lib/includes -I$(top_srcdir)/lib/includes \
+ -I$(top_builddir)/lib/gl -I$(top_srcdir)/lib/gl $(CODE_COVERAGE_CPPFLAGS)
-LDADD = ../lib/libtasn1.la ../gl/libgnu.la
+LDADD = ../lib/libtasn1.la
+LDFLAGS = $(CODE_COVERAGE_LDFLAGS)
bin_PROGRAMS = asn1Parser asn1Coding asn1Decoding