summaryrefslogtreecommitdiff
path: root/gl/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2006-11-16 09:04:54 +0000
committerSimon Josefsson <simon@josefsson.org>2006-11-16 09:04:54 +0000
commit7fb4b71c5c3f55e7686209d9993726dfaa219b27 (patch)
tree7511d256eb7c9560bbdb92f9604176e02e24d27c /gl/Makefile.am
parent6cfa79db487699e3ba7116f56df26223cc798f30 (diff)
downloadlibtasn1-7fb4b71c5c3f55e7686209d9993726dfaa219b27.tar.gz
libtasn1-7fb4b71c5c3f55e7686209d9993726dfaa219b27.tar.bz2
libtasn1-7fb4b71c5c3f55e7686209d9993726dfaa219b27.zip
Use read_binary_file to read data, for Windows. Add self-test to test regressions.
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index 1074d81..74fcbf1 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -9,7 +9,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --local-dir=gl/override --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --aux-dir=. --libtool --macro-prefix=gl gendocs getopt maintainer-makefile memmove progname strdup version-etc-fsf
+# Reproduce by: gnulib-tool --import --dir=. --local-dir=gl/override --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --aux-dir=. --libtool --macro-prefix=gl gendocs getopt maintainer-makefile memmove progname read-file strdup version-etc-fsf
AUTOMAKE_OPTIONS = 1.5 gnits
@@ -67,6 +67,13 @@ libgnu_la_SOURCES += progname.h progname.c
## end gnulib module progname
+## begin gnulib module read-file
+
+
+EXTRA_DIST += read-file.c read-file.h
+
+## end gnulib module read-file
+
## begin gnulib module strdup
@@ -102,9 +109,8 @@ libgnu_la_SOURCES += version-etc-fsf.c
mostlyclean-local: mostlyclean-generic
- @test -z "$(MOSTLYCLEANDIRS)" || \
- for dir in $(MOSTLYCLEANDIRS); do \
- if test -d $$dir; then \
- echo "rmdir $$dir"; rmdir $$dir; \
- fi; \
- done
+ @for dir in '' $(MOSTLYCLEANDIRS); do \
+ if test -n "$$dir" && test -d $$dir; then \
+ echo "rmdir $$dir"; rmdir $$dir; \
+ fi; \
+ done