summaryrefslogtreecommitdiff
path: root/gl/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2006-10-19 14:01:01 +0000
committerSimon Josefsson <simon@josefsson.org>2006-10-19 14:01:01 +0000
commit65c6a2bfac14b44dc9f966b1c68d4130a6c99a5e (patch)
tree4924b2a5230ad31e91bffd57ff37993c4b409d8f /gl/Makefile.am
parent7d89066131992c33e18c625e5e3d9ee3f9dff62a (diff)
downloadlibtasn1-65c6a2bfac14b44dc9f966b1c68d4130a6c99a5e.tar.gz
libtasn1-65c6a2bfac14b44dc9f966b1c68d4130a6c99a5e.tar.bz2
libtasn1-65c6a2bfac14b44dc9f966b1c68d4130a6c99a5e.zip
Update gnulib files, don't require LGPL modules (the libtasn1 library doesn't use gnulib).
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am39
1 files changed, 29 insertions, 10 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index 1faacb6..f63f747 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -1,3 +1,4 @@
+## DO NOT EDIT! GENERATED AUTOMATICALLY!
## Process this file with automake to produce Makefile.in.
# Copyright (C) 2004-2006 Free Software Foundation, Inc.
#
@@ -8,16 +9,17 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --aux-dir=. --lgpl --libtool --macro-prefix=gl gendocs getopt maintainer-makefile memmove strdup
+# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --aux-dir=. --libtool --macro-prefix=gl gendocs getopt maintainer-makefile memmove strdup
-AUTOMAKE_OPTIONS = 1.5 gnits no-dependencies
+AUTOMAKE_OPTIONS = 1.5 gnits
noinst_LTLIBRARIES = libgnu.la
libgnu_la_SOURCES =
-libgnu_la_LIBADD = @LTLIBOBJS@
+libgnu_la_LIBADD = $(gl_LTLIBOBJS)
+libgnu_la_DEPENDENCIES = $(gl_LTLIBOBJS)
+libgnu_la_LDFLAGS = $(AM_LDFLAGS)
noinst_HEADERS =
-pkgdata_DATA =
EXTRA_DIST =
BUILT_SOURCES =
SUFFIXES =
@@ -32,15 +34,18 @@ AM_CPPFLAGS =
## begin gnulib module getopt
BUILT_SOURCES += $(GETOPT_H)
-EXTRA_DIST += getopt_.h getopt_int.h
# We need the following in order to create <getopt.h> when the system
# doesn't have one that works with the given compiler.
getopt.h: getopt_.h
- cp $(srcdir)/getopt_.h $@-t
- mv $@-t $@
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ cat $(srcdir)/getopt_.h; \
+ } > $@-t
+ mv -f $@-t $@
MOSTLYCLEANFILES += getopt.h getopt.h-t
+EXTRA_DIST += getopt.c getopt1.c getopt_.h getopt_int.h
+
## end gnulib module getopt
## begin gnulib module gettext-h
@@ -49,6 +54,20 @@ libgnu_la_SOURCES += gettext.h
## end gnulib module gettext-h
+## begin gnulib module memmove
+
+
+EXTRA_DIST += memmove.c
+
+## end gnulib module memmove
+
+## begin gnulib module strdup
+
+
+EXTRA_DIST += strdup.c strdup.h
+
+## end gnulib module strdup
+
## begin gnulib module unistd
BUILT_SOURCES += $(UNISTD_H)
@@ -56,7 +75,9 @@ BUILT_SOURCES += $(UNISTD_H)
# We need the following in order to create an empty placeholder for
# <unistd.h> when the system doesn't have one.
unistd.h:
- echo '/* Empty placeholder for $@. */' >$@
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ echo '/* Empty placeholder for $@. */'; \
+ } > $@
MOSTLYCLEANFILES += unistd.h
## end gnulib module unistd
@@ -75,5 +96,3 @@ mostlyclean-local: mostlyclean-generic
echo "rmdir $$dir"; rmdir $$dir; \
fi; \
done
-
-# Makefile.am ends here