summaryrefslogtreecommitdiff
path: root/gl/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2010-01-12 21:26:24 +0100
committerSimon Josefsson <simon@josefsson.org>2010-01-12 21:26:24 +0100
commit49c82b023a8ea68af2941fc4b8b851ce807dd6d7 (patch)
treeda14c2681202f4282552401172351bb80c7aa239 /gl/Makefile.am
parentd7a5e23798fd7ec5f2cc077786ac9fdadca8d594 (diff)
downloadlibtasn1-49c82b023a8ea68af2941fc4b8b851ce807dd6d7.tar.gz
libtasn1-49c82b023a8ea68af2941fc4b8b851ce807dd6d7.tar.bz2
libtasn1-49c82b023a8ea68af2941fc4b8b851ce807dd6d7.zip
Update gnulib files.
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index 13c55ee..ebfa36a 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -336,7 +336,7 @@ BUILT_SOURCES += unistd.h
# We need the following in order to create an empty placeholder for
# <unistd.h> when the system doesn't have one.
-unistd.h: unistd.in.h $(LINK_WARNING_H) $(ARG_NONNULL_H)
+unistd.h: unistd.in.h $(LINK_WARNING_H) $(WARN_ON_USE_H) $(ARG_NONNULL_H)
$(AM_V_GEN)rm -f $@-t $@ && \
{ echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
sed -e 's|@''HAVE_UNISTD_H''@|$(HAVE_UNISTD_H)|g' \
@@ -438,6 +438,7 @@ unistd.h: unistd.in.h $(LINK_WARNING_H) $(ARG_NONNULL_H)
-e 's|@''UNISTD_H_HAVE_WINSOCK2_H_AND_USE_SOCKETS''@|$(UNISTD_H_HAVE_WINSOCK2_H_AND_USE_SOCKETS)|g' \
-e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \
-e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \
+ -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)' \
< $(srcdir)/unistd.in.h; \
} > $@-t && \
mv $@-t $@
@@ -480,6 +481,25 @@ libgnu_la_SOURCES += version-etc-fsf.c
## end gnulib module version-etc-fsf
+## begin gnulib module warn-on-use
+
+BUILT_SOURCES += warn-on-use.h
+# The warn-on-use.h that gets inserted into generated .h files is the same as
+# build-aux/warn-on-use.h, except that it has the copyright header cut off.
+warn-on-use.h: $(top_srcdir)/build-aux/warn-on-use.h
+ $(AM_V_GEN)rm -f $@-t $@ && \
+ sed -n -e '/^.ifndef/,$$p' \
+ < $(top_srcdir)/build-aux/warn-on-use.h \
+ > $@-t && \
+ mv $@-t $@
+MOSTLYCLEANFILES += warn-on-use.h warn-on-use.h-t
+
+WARN_ON_USE_H=warn-on-use.h
+
+EXTRA_DIST += $(top_srcdir)/build-aux/warn-on-use.h
+
+## end gnulib module warn-on-use
+
## begin gnulib module wchar
BUILT_SOURCES += wchar.h