summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Schroeder <mls@suse.de>2012-10-15 12:10:06 +0200
committerMichael Schroeder <mls@suse.de>2012-10-15 12:10:06 +0200
commitd5597d3b349415e684814541d33b1b460a0481b9 (patch)
tree820f839caf3b8bcfcc72e26052c651e78d40531b /CMakeLists.txt
parenta9bc7b08e9fb6dd1dd18d922d90fb773ca6ecdf8 (diff)
downloadlibsolv-d5597d3b349415e684814541d33b1b460a0481b9.tar.gz
libsolv-d5597d3b349415e684814541d33b1b460a0481b9.tar.bz2
libsolv-d5597d3b349415e684814541d33b1b460a0481b9.zip
add repo_add_rpm_handle, add ENABLE_RPMDB_BYRPMHEADER so that we don't need to link against rpm if rpm_byrpmh is not needed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d5b86a..ae536ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ OPTION (USE_VENDORDIRS "Install the bindings in vendor directories?" OFF)
OPTION (ENABLE_RPMDB "Build with rpm database support?" OFF)
OPTION (ENABLE_RPMDB_PUBKEY "Build with rpmdb pubkey support?" OFF)
+OPTION (ENABLE_RPMDB_BYRPMHEADER "Build with rpmdb Header support?" OFF)
OPTION (ENABLE_RPMMD "Build with rpmmd repository support?" OFF)
OPTION (ENABLE_SUSEREPO "Build with suse repository support?" OFF)
OPTION (ENABLE_COMPS "Build with fedora comps support?" OFF)
@@ -77,6 +78,7 @@ MESSAGE (STATUS "Building for SUSE")
ADD_DEFINITIONS (-DSUSE)
SET (ENABLE_RPMDB ON)
SET (ENABLE_RPMDB_PUBKEY ON)
+SET (ENABLE_RPMDB_BYRPMHEADER ON)
SET (ENABLE_RPMMD ON)
SET (ENABLE_SUSEREPO ON)
SET (ENABLE_HELIXREPO ON)