summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Schroeder <mls@suse.de>2011-07-13 18:46:17 +0200
committerMichael Schroeder <mls@suse.de>2011-07-13 18:46:17 +0200
commit96d3ffea9f0ab1a454a9f48e698291d89d0ec22b (patch)
tree41d757114a6734037d8e8d868048938de5abcb42 /CMakeLists.txt
parent09f29f706df0cf171ba7e7e8a3272388039630e4 (diff)
downloadlibsolv-96d3ffea9f0ab1a454a9f48e698291d89d0ec22b.tar.gz
libsolv-96d3ffea9f0ab1a454a9f48e698291d89d0ec22b.tar.bz2
libsolv-96d3ffea9f0ab1a454a9f48e698291d89d0ec22b.zip
- add support for bindings creation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9634bc3..1afd2eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,10 @@ CMAKE_MINIMUM_REQUIRED (VERSION 2.4)
OPTION(ENABLE_STATIC "Build a static version of the libraries?" OFF)
OPTION(DISABLE_SHARED "Do not build a shared version of the libraries?" OFF)
+OPTION(ENABLE_PERL "Build the perl bindings?" OFF)
+OPTION(ENABLE_PYTHON "Build the python bindings?" OFF)
+OPTION(ENABLE_RUBY "Build the ruby bindings?" OFF)
+
#IF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERISION} GREATER 2.4)
#ENDIF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERISION} GREATER 2.4)
@@ -182,6 +186,9 @@ set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS} -g3 -O0")
ADD_SUBDIRECTORY (src)
ADD_SUBDIRECTORY (ext)
ADD_SUBDIRECTORY (tools)
+IF (ENABLE_PERL OR ENABLE_PYTHON OR ENABLE_RUBY)
+ ADD_SUBDIRECTORY (bindings)
+ENDIF (ENABLE_PERL OR ENABLE_PYTHON OR ENABLE_RUBY)
ADD_SUBDIRECTORY (examples)
MESSAGE (STATUS "version: ${VERSION}")