summaryrefslogtreecommitdiff
path: root/libcap-ng.spec
diff options
context:
space:
mode:
authorDariusz Michaluk <d.michaluk@samsung.com>2024-02-16 12:29:59 +0100
committerDariusz Michaluk <d.michaluk@samsung.com>2024-02-16 12:29:59 +0100
commit3ec0912f27cde058107543db7e8e6a65e44d18b3 (patch)
tree02a7601c2964f9c712b919a223dda094ff0c2369 /libcap-ng.spec
parentc591394f75d0462d9d9a17d66c1bcf800181a294 (diff)
downloadlibcap-ng-3ec0912f27cde058107543db7e8e6a65e44d18b3.tar.gz
libcap-ng-3ec0912f27cde058107543db7e8e6a65e44d18b3.tar.bz2
libcap-ng-3ec0912f27cde058107543db7e8e6a65e44d18b3.zip
Imported Upstream version 0.8.4upstream/0.8.4upstream
Diffstat (limited to 'libcap-ng.spec')
-rw-r--r--libcap-ng.spec73
1 files changed, 29 insertions, 44 deletions
diff --git a/libcap-ng.spec b/libcap-ng.spec
index c5a83d5..0719d40 100644
--- a/libcap-ng.spec
+++ b/libcap-ng.spec
@@ -1,9 +1,7 @@
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
-
-Summary: An alternate posix capabilities library
+Summary: An alternate POSIX capabilities library
Name: libcap-ng
-Version: 0.6.6
-Release: 1
+Version: 0.8.4
+Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://people.redhat.com/sgrubb/libcap-ng
@@ -13,7 +11,7 @@ BuildRequires: kernel-headers >= 2.6.11
BuildRequires: libattr-devel
%description
-Libcap-ng is a library that makes using posix capabilities easier
+Libcap-ng is a library that makes using POSIX capabilities easier
%package devel
Summary: Header files for libcap-ng library
@@ -27,82 +25,69 @@ Requires: pkgconfig
The libcap-ng-devel package contains the files needed for developing
applications that need to use the libcap-ng library.
-%package python
-Summary: Python bindings for libcap-ng library
+%package python3
+Summary: Python3 bindings for libcap-ng library
License: LGPLv2+
Group: Development/Libraries
-BuildRequires: python-devel swig
+BuildRequires: python3-devel swig
Requires: %{name} = %{version}-%{release}
-%description python
-The libcap-ng-python package contains the bindings so that libcap-ng
-and can be used by python applications.
+%description python3
+The libcap-ng-python3 package contains the bindings so that libcap-ng
+and can be used by python3 applications.
%package utils
-Summary: Utilities for analysing and setting file capabilities
+Summary: Utilities for analyzing and setting file capabilities
License: GPLv2+
Group: Development/Libraries
%description utils
-The libcap-ng-utils package contains applications to analyse the
-posix capabilities of all the program running on a system. It also
+The libcap-ng-utils package contains applications to analyze the
+POSIX capabilities of all the program running on a system. It also
lets you set the file system based capabilities.
%prep
%setup -q
%build
-%configure --libdir=/%{_lib}
-make %{?_smp_mflags}
+%configure --libdir=%{_libdir} --with-python3
+make CFLAGS="%{optflags}" %{?_smp_mflags}
%install
-rm -rf $RPM_BUILD_ROOT
-make DESTDIR="${RPM_BUILD_ROOT}" install
-
-# Move the symlink
-rm -f $RPM_BUILD_ROOT/%{_lib}/%{name}.so
-mkdir -p $RPM_BUILD_ROOT%{_libdir}
-VLIBNAME=$(ls $RPM_BUILD_ROOT/%{_lib}/%{name}.so.*.*.*)
-LIBNAME=$(basename $VLIBNAME)
-ln -s ../../%{_lib}/$LIBNAME $RPM_BUILD_ROOT%{_libdir}/%{name}.so
-
-# Move the pkgconfig file
-mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
+make DESTDIR="${RPM_BUILD_ROOT}" INSTALL='install -p' install
# Remove a couple things so they don't get picked up
-rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.la
-rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.a
+rm -f $RPM_BUILD_ROOT/%{_libdir}/libcap-ng.la
+rm -f $RPM_BUILD_ROOT/%{_libdir}/libcap-ng.a
+rm -f $RPM_BUILD_ROOT/%{_libdir}/libdrop_ambient.la
+rm -f $RPM_BUILD_ROOT/%{_libdir}/libdrop_ambient.a
rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.a
rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.la
%check
make check
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
+%ldconfig_scriptlets
%files
%defattr(-,root,root,-)
%doc COPYING.LIB
-%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
+/%{_libdir}/libcap-ng.so.*
+/%{_libdir}/libdrop_ambient.so.*
+%attr(0644,root,root) %{_mandir}/man7/*
%files devel
%defattr(-,root,root,-)
%attr(0644,root,root) %{_mandir}/man3/*
%attr(0644,root,root) %{_includedir}/cap-ng.h
-%attr(0755,root,root) %{_libdir}/libcap-ng.so
+%{_libdir}/libcap-ng.so
+%{_libdir}/libdrop_ambient.so
%attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
%{_libdir}/pkgconfig/libcap-ng.pc
-%files python
+%files python3
%defattr(-,root,root,-)
-%attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
-%{python_sitearch}/capng.py*
+%attr(755,root,root) %{python3_sitearch}/*
%files utils
%defattr(-,root,root,-)
@@ -111,6 +96,6 @@ rm -rf $RPM_BUILD_ROOT
%attr(0644,root,root) %{_mandir}/man8/*
%changelog
-* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
+* Wed Dec 20 2023 Steve Grubb <sgrubb@redhat.com> 0.8.4-1
- New upstream release