summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjulie <julielangou@users.noreply.github.com>2012-04-12 21:07:52 +0000
committerjulie <julielangou@users.noreply.github.com>2012-04-12 21:07:52 +0000
commite920f07b5587768435d6c94585c700bd17692221 (patch)
treecfd411b0fcc1f143318d1c99fb61c2bab22160b2 /CMakeLists.txt
parentd1c0c25cd21baff8edfe9273b2f975ac81da2703 (diff)
downloadlapack-e920f07b5587768435d6c94585c700bd17692221.tar.gz
lapack-e920f07b5587768435d6c94585c700bd17692221.tar.bz2
lapack-e920f07b5587768435d6c94585c700bd17692221.zip
Add -qnosave option for xlf compiler (Thanks Rodney)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0f9cd1f..9d022513 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,9 @@ if (UNIX)
if ( "${CMAKE_Fortran_COMPILER}" MATCHES "ifort" )
set( CMAKE_Fortran_FLAGS "${CMAKE_Fortran_FLAGS} -fltconsistency -fp_port" )
endif ()
+ if ( "${CMAKE_Fortran_COMPILER}" MATCHES "xlf" )
+ set( CMAKE_Fortran_FLAGS "${CMAKE_Fortran_FLAGS} -qnosave" )
+ endif ()
# Delete libmtsk in linking sequence for Sun/Oracle Fortran Compiler.
# This library is not present in the Sun package SolarisStudio12.3-linux-x86-bin
STRING(REPLACE \;mtsk\; \; CMAKE_Fortran_IMPLICIT_LINK_LIBRARIES "${CMAKE_Fortran_IMPLICIT_LINK_LIBRARIES}")