summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjulie <julielangou@users.noreply.github.com>2010-12-20 22:54:32 +0000
committerjulie <julielangou@users.noreply.github.com>2010-12-20 22:54:32 +0000
commit96a5907fbc5787b9b8e45d9acc9033af7a112718 (patch)
tree8408c67caab57cf0585e608c958ab552490ee89c /CMakeLists.txt
parent20d3177888b19f48f750f67a24a41fd2422efedb (diff)
downloadlapack-96a5907fbc5787b9b8e45d9acc9033af7a112718.tar.gz
lapack-96a5907fbc5787b9b8e45d9acc9033af7a112718.tar.bz2
lapack-96a5907fbc5787b9b8e45d9acc9033af7a112718.zip
Added a CTestCustom.cmake file to filter unwanted files from code coverage and suppress harmless warnings on the dashboard.
- Chuck Atkins (Kitware)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a9cc476..b25d0285 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,13 @@
cmake_minimum_required(VERSION 2.6)
project(LAPACK Fortran)
+# Configure the warning and code coverage suppression file
+configure_file(
+ "${LAPACK_SOURCE_DIR}/CTestCustom.cmake.in"
+ "${LAPACK_BINARY_DIR}/CTestCustom.cmake"
+ COPYONLY
+)
+
# Add the CMake directory for custon CMake modules
set(CMAKE_MODULE_PATH "${LAPACK_SOURCE_DIR}/CMAKE" ${CMAKE_MODULE_PATH})