summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuillaume Jacquenot <guillaume.jacquenot@gmail.com>2017-02-21 21:22:25 +0100
committerGuillaume Jacquenot <guillaume.jacquenot@gmail.com>2017-02-21 21:22:25 +0100
commit52b6f36bd622845656d766ba54acd30b8de582fe (patch)
tree985c03c5d8be21ef61f09fcc135a28f129cdad5c /CMakeLists.txt
parentf7f9d972a73593fac5daaa7c7c942762ee54548b (diff)
downloadlapack-52b6f36bd622845656d766ba54acd30b8de582fe.tar.gz
lapack-52b6f36bd622845656d766ba54acd30b8de582fe.tar.bz2
lapack-52b6f36bd622845656d766ba54acd30b8de582fe.zip
[coverage] Added CMake rules for code coverage
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c50b5010..eed3796e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
message(STATUS "Setting build type to 'Release' as none was specified.")
set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build." FORCE)
# Set the possible values of build type for cmake-gui
- set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "Debug" "Release" "MinSizeRel" "RelWithDebInfo")
+ set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "Debug" "Release" "MinSizeRel" "RelWithDebInfo" "Coverage")
endif()
project(LAPACK Fortran C)
@@ -134,6 +134,12 @@ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LAPACK_BINARY_DIR}/lib)
include(CheckLAPACKCompilerFlags)
CheckLAPACKCompilerFlags()
+string(TOUPPER ${CMAKE_BUILD_TYPE} CMAKE_BUILD_TYPE_UPPER)
+if(${CMAKE_BUILD_TYPE_UPPER} STREQUAL "COVERAGE")
+ message(STATUS "Adding coverage")
+ find_package(codecov)
+endif()
+
# --------------------------------------------------
# Check second function