summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjulie <julielangou@users.noreply.github.com>2010-12-15 18:08:26 +0000
committerjulie <julielangou@users.noreply.github.com>2010-12-15 18:08:26 +0000
commit1ab7dfd850b653f6cddc1fcba6c1a71498449090 (patch)
tree29efdda57050fbc901b568fd5dc2298cf07974e7 /CMakeLists.txt
parentfc27aaf2d33a3d193b8b36c3a6abca06c46376e1 (diff)
downloadlapack-1ab7dfd850b653f6cddc1fcba6c1a71498449090.tar.gz
lapack-1ab7dfd850b653f6cddc1fcba6c1a71498449090.tar.bz2
lapack-1ab7dfd850b653f6cddc1fcba6c1a71498449090.zip
minor modif on find BLAS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b588acd..1f7a4bb4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,16 +46,16 @@ set(DSECOND_SRC ${LAPACK_SOURCE_DIR}/INSTALL/dsecnd_${TIME_FUNC}.f)
# --------------------------------------------------
# Subdirectories that need to be processed
-option(USE_SYSTEM_BLAS "Whether or not to use an external BLAS library or the
-included netlib BLAS" OFF)
-if( USE_SYSTEM_BLAS )
+option(LOOK_FOR_OPTIMZED_BLAS "Whether or not to use an optimized BLAS library or the included netlib BLAS" OFF)
+if( LOOK_FOR_OPTIMZED_BLAS )
find_package( BLAS )
-endif(USE_SYSTEM_BLAS)
+endif(LOOK_FOR_OPTIMZED_BLAS)
if(NOT BLAS_FOUND)
add_subdirectory(BLAS)
set( BLAS_LIBRARIES blas )
endif( NOT BLAS_FOUND )
+
add_subdirectory(SRC)
add_subdirectory(TESTING)