summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-26 16:10:41 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-26 16:14:18 -0200
commitf6ef5d6b5fa47ab5fa9c9275eaa38916b92ca5a4 (patch)
tree911dfaf64d3d8feaa512fcc29a93a448d24e013d /Makefile.am
parentd2c2b8b500bfea8882dea0b6f0b68d8531860ea8 (diff)
downloadkmod-f6ef5d6b5fa47ab5fa9c9275eaa38916b92ca5a4.tar.gz
kmod-f6ef5d6b5fa47ab5fa9c9275eaa38916b92ca5a4.tar.bz2
kmod-f6ef5d6b5fa47ab5fa9c9275eaa38916b92ca5a4.zip
testsuite: trap calls to delete_module() including simple test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 242d3e6..22e882b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -134,7 +134,8 @@ endif
# ------------------------------------------------------------------------------
TESTSUITE_OVERRIDE_LIBS = testsuite/uname.la testsuite/path.la \
- testsuite/init_module.la
+ testsuite/init_module.la \
+ testsuite/delete_module.la
TESTSUITE_OVERRIDE_LIBS_LDFLAGS = avoid-version -module -shared -export-dynamic \
-rpath /nowhere -ldl
@@ -143,6 +144,7 @@ check_LTLIBRARIES = $(TESTSUITE_OVERRIDE_LIBS)
testsuite_uname_la_LDFLAGS = $(TESTSUITE_OVERRIDE_LIBS_LDFLAGS)
testsuite_path_la_LDFLAGS = $(TESTSUITE_OVERRIDE_LIBS_LDFLAGS)
+testsuite_delete_module_la_LDFLAGS = $(TESTSUITE_OVERRIDE_LIBS_LDFLAGS)
testsuite_init_module_la_LDFLAGS = $(TESTSUITE_OVERRIDE_LIBS_LDFLAGS)
testsuite_init_module_la_SOURCES = testsuite/init_module.c \
testsuite/stripped_module.h