summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2012-06-19 13:09:23 -0300
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2012-06-19 13:27:56 -0300
commit33202e84f344794b1ae261874883874a2c15dc80 (patch)
treec178abcf592bcc2a63858634cc0740a37dd4e217 /Makefile.am
parent3f376cd87742246f00fe552596975a00ec5d60b1 (diff)
downloadkmod-33202e84f344794b1ae261874883874a2c15dc80.tar.gz
kmod-33202e84f344794b1ae261874883874a2c15dc80.tar.bz2
kmod-33202e84f344794b1ae261874883874a2c15dc80.zip
build-sys: Make dirs writable on rootfs creation
Autofoo make the dist dir as readonly. If we copy it, tools needing to create sysfs entries will not be able to do so, because they can't create the needed directories/files. It would be much better if autofoo allowed to let the files as is instead of converting them to read-only.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bfa8f1..d681118 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -127,7 +127,8 @@ ROOTFS = testsuite/rootfs
ROOTFS_PRISTINE = $(top_srcdir)/testsuite/rootfs-pristine
CREATE_ROOTFS = $(AM_V_GEN) ( $(RM) -rf $(ROOTFS) && \
cp -r $(ROOTFS_PRISTINE) $(ROOTFS) && \
- touch testsuite/stamp-rootfs )
+ touch testsuite/stamp-rootfs && \
+ find $(ROOTFS) -type d -exec chmod +w {} \; )
rootfs:
$(CREATE_ROOTFS)
@@ -193,7 +194,6 @@ testsuite_test_dependencies_LDADD = $(TESTSUITE_LDADD)
testsuite_test_dependencies_CPPFLAGS = $(TESTSUITE_CPPFLAGS)
testsuite-distclean:
- -find $(ROOTFS) -type d -exec chmod +w {} \;
-$(RM) -rf $(ROOTFS)
-$(RM) testsuite/stamp-rootfs