summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2021-12-16 10:37:54 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2021-12-16 10:37:54 +0900
commitd830b8c97b430e1c41c2f014b8b464bc849a1376 (patch)
tree708c357ded732e19d18bd74ab3b3f8d9a3581ed8 /Makefile.am
parent4bab029feab593af0d9976e7b8fc7a812ee1f82d (diff)
downloadiso-codes-d830b8c97b430e1c41c2f014b8b464bc849a1376.tar.gz
iso-codes-d830b8c97b430e1c41c2f014b8b464bc849a1376.tar.bz2
iso-codes-d830b8c97b430e1c41c2f014b8b464bc849a1376.zip
Imported Upstream version 4.1upstream/4.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2fbdd6d..8264457 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ dist_json_DATA = $(wildcard $(srcdir)/data/*.json)
# the common Makefile snippet
# and the markdown documentation currently not handled
# by automake
-EXTRA_DIST = bin bootstrap common.mk README.md
+EXTRA_DIST = bin bootstrap common.mk README.md ChangeLog.md
DISTCLEANFILES = $(pkgconfig_DATA)
@@ -22,6 +22,13 @@ pot:
cd $$domain && make $$domain.pot && cd ..; \
done
+# Updates all xml files
+.PHONY: xml
+xml:
+ for domain in $(DOMAINS); do \
+ cd $$domain && make $$domain.xml && cd ..; \
+ done
+
.PHONY: release
release: update-po check distcheck