summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSven Verdoolaege <skimo@kotnet.org>2008-12-02 21:22:01 +0100
committerSven Verdoolaege <skimo@kotnet.org>2008-12-02 21:34:33 +0100
commit21f70a2e26e7ea5466f56abd0087eea6eeda91fa (patch)
tree40dc58aacf2a3392cb6e173cb11809afb82b0ae4 /configure.ac
parentf6038f29c474ee9916c67ad8d040aeaaa8ab09af (diff)
downloadisl-21f70a2e26e7ea5466f56abd0087eea6eeda91fa.tar.gz
isl-21f70a2e26e7ea5466f56abd0087eea6eeda91fa.tar.bz2
isl-21f70a2e26e7ea5466f56abd0087eea6eeda91fa.zip
Add backup mp_get_memory_functions implementation for use with old gmps
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c9e2089..e084a75b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,14 @@ if test "x$with_gmp_prefix" != "x"; then
GMP_CPPFLAGS="-I$with_gmp_prefix/include"
GMP_LDFLAGS="-L$with_gmp_prefix/lib"
fi
+SAVE_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$GMP_CPPFLAGS $CPPFLAGS"
+need_get_memory_functions=false
+AC_CHECK_DECLS(mp_get_memory_functions,[],[
+ need_get_memory_functions=true
+],[#include <gmp.h>])
+CPPFLAGS="$SAVE_CPPFLAGS"
+AM_CONDITIONAL(NEED_GET_MEMORY_FUNCTIONS, test x$need_get_memory_functions = xtrue)
AC_DEFUN([ISL_SUBMODULE],[
AC_ARG_WITH($1_prefix,