summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSven Verdoolaege <skimo@purples.(none)>2009-09-06 18:00:03 +0200
committerSven Verdoolaege <skimo@purples.(none)>2009-09-06 18:05:58 +0200
commit0820c67357171b33aaafd87641299955df85a3e0 (patch)
tree0761ff563d853ae493b8e835aa7c563a37ef83e3 /configure.ac
parente26a705634d66f36eee1165debda99d131a6b418 (diff)
downloadisl-0820c67357171b33aaafd87641299955df85a3e0.tar.gz
isl-0820c67357171b33aaafd87641299955df85a3e0.tar.bz2
isl-0820c67357171b33aaafd87641299955df85a3e0.zip
add a rudimentary manual
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f7d49253..31a1414d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,12 @@ AX_CC_MAXOPT
AC_PROG_LIBTOOL
+AC_CHECK_PROG(PERL, perl, perl, [])
+AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex, [])
+AC_CHECK_PROG(POD2HTML, pod2html, pod2html, [])
+
+AM_CONDITIONAL(GENERATE_DOC, test -n "$PERL" -a -n "$PDFLATEX" -a -n "$POD2HTML")
+
AX_CREATE_STDINT_H(include/isl_stdint.h)
AX_SUBMODULE(gmp,system,system)
@@ -130,6 +136,7 @@ AM_CONDITIONAL(BUNDLED_PIPLIB, test $with_piplib = bundled)
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_HEADERS(include/isl_libs.h)
AC_CONFIG_FILES(Makefile)
+AC_CONFIG_FILES(doc/Makefile)
if test $with_piplib = bundled; then
AC_CONFIG_SUBDIRS(piplib)
fi