summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Verdoolaege <skimo@kotnet.org>2010-02-14 19:04:13 +0100
committerSven Verdoolaege <skimo@kotnet.org>2010-02-15 11:41:36 +0100
commitadf6f98ef87dfd0f936ecff40c5cf4ef9626019f (patch)
tree8a090e2fec3238dd9df0134d3ffe4485531c7fb8 /Makefile.am
parent7986f7ab451427319bcfe5d01c89433bde46d72d (diff)
downloadisl-adf6f98ef87dfd0f936ecff40c5cf4ef9626019f.tar.gz
isl-adf6f98ef87dfd0f936ecff40c5cf4ef9626019f.tar.bz2
isl-adf6f98ef87dfd0f936ecff40c5cf4ef9626019f.zip
add isl_closure test application
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 85815bbe..eaf3becf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,8 @@ ACLOCAL_AMFLAGS = -I m4
lib_LTLIBRARIES = libisl.la
noinst_PROGRAMS = isl_test isl_polyhedron_sample isl_pip \
isl_polyhedron_minimize isl_polytope_scan \
- isl_polyhedron_detect_equalities isl_cat
+ isl_polyhedron_detect_equalities isl_cat \
+ isl_closure
TESTS = isl_test
if HAVE_PIPLIB
@@ -128,6 +129,12 @@ isl_cat_LDADD = libisl.la
isl_cat_SOURCES = \
cat.c
+isl_closure_CPPFLAGS = -I$(srcdir)/include -Iinclude/ \
+ @GMP_CPPFLAGS@
+isl_closure_LDADD = libisl.la
+isl_closure_SOURCES = \
+ closure.c
+
nodist_pkginclude_HEADERS = \
include/isl_config.h \
include/isl_stdint.h