summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTobias Grosser <grosser@fim.uni-passau.de>2010-12-30 15:12:21 -0500
committerSven Verdoolaege <skimo@kotnet.org>2010-12-31 09:50:36 +0100
commit262432efe8d0e323cf83ed98319378a249aa9a92 (patch)
tree27e116498586028d646f4c0f11a6e19fa446642a /Makefile.am
parent843d3aa51424772422f78b3454a0fd3f855d437d (diff)
downloadisl-262432efe8d0e323cf83ed98319378a249aa9a92.tar.gz
isl-262432efe8d0e323cf83ed98319378a249aa9a92.tar.bz2
isl-262432efe8d0e323cf83ed98319378a249aa9a92.zip
Add GDB module that defines an islprint command
Add a python library that is installed next to libisl. GDB will automatically load it and add a new gdbcommand called "islprint". This command can be used to prettyprint isl values. It does not install an official pretty printer, as such a printer will also pretty print stacktraces which may reference values already freed. Before: (gdb) print stride $1 = (isl_set *) 0x122e6c0 Now also possible: (gdb) islprint stride $1 = "{ MemRef_A[1] }" (gdb) is stride $1 = "{ MemRef_A[1] }" Signed-off-by: Tobias Grosser <grosser@fim.uni-passau.de> Signed-off-by: Sven Verdoolaege <skimo@kotnet.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 578981d4..54088f51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -197,6 +197,7 @@ EXTRA_DIST = \
basis_reduction_templ.c \
isl_pw_templ.c \
isl_union_templ.c \
+ isl.py \
doc/chicago.bst \
doc/chicago.sty \
doc/implementation.tex \
@@ -218,3 +219,11 @@ pkgconfig_DATA = $(pkgconfig_libfile)
gitversion.h: @GIT_HEAD@
echo '#define GIT_HEAD_ID "'@GIT_HEAD_VERSION@'"' > $@
+
+install-data-local: $(srcdir)/isl.py
+ @libisl=`sed -ne "/^library_names=/{s/.*='//;s/'$$//;s/ .*//;p}" \
+ $(builddir)/libisl.la`; \
+ case $$libisl in \
+ '') echo Cannot find isl library name. GDB bindings not installed.;; \
+ *) echo $(INSTALL_DATA) $(srcdir)/isl.py $(libdir)/$$libisl-gdb.py; \
+ $(INSTALL_DATA) $(srcdir)/isl.py $(libdir)/$$libisl-gdb.py; esac