summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Verdoolaege <skimo@kotnet.org>2008-12-02 21:22:01 +0100
committerSven Verdoolaege <skimo@kotnet.org>2008-12-02 21:34:33 +0100
commit21f70a2e26e7ea5466f56abd0087eea6eeda91fa (patch)
tree40dc58aacf2a3392cb6e173cb11809afb82b0ae4 /Makefile.am
parentf6038f29c474ee9916c67ad8d040aeaaa8ab09af (diff)
downloadisl-21f70a2e26e7ea5466f56abd0087eea6eeda91fa.tar.gz
isl-21f70a2e26e7ea5466f56abd0087eea6eeda91fa.tar.bz2
isl-21f70a2e26e7ea5466f56abd0087eea6eeda91fa.zip
Add backup mp_get_memory_functions implementation for use with old gmps
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f78b808..78ab76a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,9 +33,14 @@ if BUNDLED_PIPLIB
PIPLIB_LA = $(top_builddir)/piplib/libpiplibMP.la
endif
+if NEED_GET_MEMORY_FUNCTIONS
+GET_MEMORY_FUNCTIONS=mp_get_memory_functions.c
+endif
+
libisl_la_SOURCES = \
$(ISL_PIPLIB) \
$(ISL_POLYLIB) \
+ $(GET_MEMORY_FUNCTIONS) \
isl_affine_hull.c \
isl_blk.c \
isl_constraint.c \