summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Verdoolaege <skimo@kotnet.org>2009-08-07 21:31:45 +0200
committerSven Verdoolaege <skimo@kotnet.org>2009-08-28 19:42:19 +0200
commit00472a3bcaa72cf398d235d3b345aa4ede3479db (patch)
tree48f992ebc14b794c3bca146a9cbb1e17eb6ece1e /Makefile.am
parent708bb34fa63da00f1ff5de37b050777ebc719fb9 (diff)
downloadisl-00472a3bcaa72cf398d235d3b345aa4ede3479db.tar.gz
isl-00472a3bcaa72cf398d235d3b345aa4ede3479db.tar.bz2
isl-00472a3bcaa72cf398d235d3b345aa4ede3479db.zip
add isl_polyhedron_minimize application
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 70b501f6..4bcb94fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,8 @@ DIST_SUBDIRS = $(MAYBE_PIPLIB)
ACLOCAL_AMFLAGS = -I m4
lib_LTLIBRARIES = libisl.la
-noinst_PROGRAMS = isl_test isl_polyhedron_sample isl_pip
+noinst_PROGRAMS = isl_test isl_polyhedron_sample isl_pip \
+ isl_polyhedron_minimize
TESTS = isl_test
if HAVE_POLYLIB
@@ -113,6 +114,12 @@ isl_pip_LDADD = libisl.la
isl_pip_SOURCES = \
pip.c
+isl_polyhedron_minimize_CPPFLAGS = -I$(srcdir)/include -Iinclude/ \
+ @GMP_CPPFLAGS@
+isl_polyhedron_minimize_LDADD = libisl.la
+isl_polyhedron_minimize_SOURCES = \
+ polyhedron_minimize.c
+
nodist_pkginclude_HEADERS = \
include/isl_ctx.h \
include/isl_stdint.h