summaryrefslogtreecommitdiff
path: root/hl/fortran/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/fortran/Makefile.am')
-rw-r--r--hl/fortran/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/hl/fortran/Makefile.am b/hl/fortran/Makefile.am
new file mode 100644
index 0000000..ad18a21
--- /dev/null
+++ b/hl/fortran/Makefile.am
@@ -0,0 +1,45 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the COPYING file, which can be found at the root of the source code
+# distribution tree, or in https://support.hdfgroup.org/ftp/HDF5/releases.
+# If you do not have access to either file, you may request a copy from
+# help@hdfgroup.org.
+#
+#
+# This makefile mostly just reinvokes make in the various subdirectories
+# but does so in the correct order. You can alternatively invoke make from
+# each subdirectory manually.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+##
+#
+# HDF5 High-Level Makefile(.in)
+
+include $(top_srcdir)/config/commence.am
+
+SUBDIRS=src test
+DIST_SUBDIRS=src test examples
+
+# Install examples
+install-examples uninstall-examples:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+
+installcheck-local:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+
+# Clean examples when check-clean is invoked
+check-clean ::
+ @$(MAKE) $(AM_MAKEFLAGS) build-$@ || exit 1;
+ @for d in X $(SUBDIRS) examples; do \
+ if test $$d != X && test $$d != .; then \
+ (set -x; cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ fi; \
+ done
+
+include $(top_srcdir)/config/conclude.am