summaryrefslogtreecommitdiff
path: root/lang/python/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/tests/Makefile.am')
-rw-r--r--lang/python/tests/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/lang/python/tests/Makefile.am b/lang/python/tests/Makefile.am
index 25b15f2..3864f8b 100644
--- a/lang/python/tests/Makefile.am
+++ b/lang/python/tests/Makefile.am
@@ -18,8 +18,6 @@
GPG = gpg
GPG_AGENT = gpg-agent
-export GNUPGHOME := $(abs_builddir)
-export GPG_AGENT_INFO :=
test_srcdir = $(top_srcdir)/tests/gpg
@@ -79,7 +77,7 @@ xcheck: all
CLEANFILES = secring.gpg pubring.gpg pubring.kbx trustdb.gpg dirmngr.conf \
gpg-agent.conf pubring.kbx~ gpg.conf pubring.gpg~ \
random_seed .gpg-v21-migrated tofu.db \
- pubring-stamp private-keys-v1.d/gpg-sample.stamp
+ pubring-stamp gpg-sample.stamp
private_keys = \
$(test_srcdir)/13CD0F3BDF24BE53FE192D62F18737256FF6E4FD \
@@ -89,26 +87,25 @@ private_keys = \
$(test_srcdir)/7A030357C0F253A5BBCD282FFC4E521B37558F5C
clean-local:
- -$(top_srcdir)/tests/start-stop-agent --stop
+ -$(TESTS_ENVIRONMENT) $(top_srcdir)/tests/start-stop-agent --stop
-rm -fR -- private-keys-v1.d openpgp-revocs.d S.gpg-agent sshcontrol
BUILT_SOURCES = gpg.conf gpg-agent.conf pubring-stamp \
- private-keys-v1.d/gpg-sample.stamp
+ gpg-sample.stamp
-private-keys-v1.d/gpg-sample.stamp: $(private_keys)
- -gpgconf --kill all
+gpg-sample.stamp: $(private_keys)
+ -$(TESTS_ENVIRONMENT) gpgconf --kill all
$(MKDIR_P) ./private-keys-v1.d
for k in $(private_keys); do \
cp $$k private-keys-v1.d/$${k#$(test_srcdir)/}.key; \
done
- echo x > ./private-keys-v1.d/gpg-sample.stamp
+ echo x > ./gpg-sample.stamp
-pubring-stamp: $(test_srcdir)/pubdemo.asc \
- ./private-keys-v1.d/gpg-sample.stamp
- $(GPG) --batch --no-permission-warning \
+pubring-stamp: $(test_srcdir)/pubdemo.asc gpg-sample.stamp
+ $(TESTS_ENVIRONMENT) $(GPG) --batch --no-permission-warning \
--import $(test_srcdir)/pubdemo.asc
- -$(GPG) --batch --no-permission-warning \
+ -$(TESTS_ENVIRONMENT) $(GPG) --batch --no-permission-warning \
--import $(test_srcdir)/secdemo.asc
echo x > ./pubring-stamp