summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJinWang An <jinwang.an@samsung.com>2021-12-01 16:54:38 +0900
committerJinWang An <jinwang.an@samsung.com>2021-12-01 16:54:38 +0900
commita4cc2ca8c024d3187c4ff465a176c7585b533411 (patch)
tree659217ad9dfa42858c46dfafb7770a1ee67d2894 /Makefile.am
parent56c3832bc03cffe24fcca71370b668a6678d0cf9 (diff)
downloadgpgme-a4cc2ca8c024d3187c4ff465a176c7585b533411.tar.gz
gpgme-a4cc2ca8c024d3187c4ff465a176c7585b533411.tar.bz2
gpgme-a4cc2ca8c024d3187c4ff465a176c7585b533411.zip
Imported Upstream version 1.13.0upstream/1.13.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 829cf14..1772d69 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,8 @@
# Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, see <https://www.gnu.org/licenses/>.
+# License along with this program; if not, see <https://gnu.org/licenses/>.
+# SPDX-License-Identifier: LGPL-2.1-or-later
## Process this file with automake to produce Makefile.in
@@ -33,9 +34,9 @@ ACLOCAL_AMFLAGS = -I m4
DISTCHECK_CONFIGURE_FLAGS =
-EXTRA_DIST = autogen.sh autogen.rc gpgme.spec.in \
- ChangeLog-2011 m4/ChangeLog-2011 contrib/ChangeLog-2011 \
- conf/whatisthis
+EXTRA_DIST = autogen.sh autogen.rc gpgme.spec.in \
+ ChangeLog-2011 m4/ChangeLog-2011 \
+ conf/whatisthis VERSION
if RUN_GPG_TESTS
@@ -46,13 +47,11 @@ endif
SUBDIRS = src ${tests} doc lang
-# Fix the version of the spec file and create a file named VERSION
-# to be used for patch's Prereq: feature.
+# Fix the version of the spec file.
dist-hook: gen-ChangeLog
@set -e; \
sed -e 's/@pkg_version@/$(PACKAGE_VERSION)/g' \
$(top_srcdir)/gpgme.spec.in > $(distdir)/gpgme.spec
- echo "$(PACKAGE_VERSION)" > $(distdir)/VERSION
distcheck-hook:
set -e; ( \
@@ -101,7 +100,7 @@ release:
$(MAKE) distcheck TESTFLAGS=--parallel; \
echo "/* Build finished at $$(date -uIseconds) */" ;\
echo "/*" ;\
- echo " * Please run the final step interactivly:" ;\
+ echo " * Please run the final step interactively:" ;\
echo " * make sign-release" ;\
echo " */" ;\
) 2>&1 | tee "$(RELEASE_NAME).buildlog"