summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build20
1 files changed, 18 insertions, 2 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index 8bf555cf2..a1b41872d 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -55,7 +55,7 @@ gio_tests = {
'memory-output-stream' : {},
'monitor' : {},
'mount-operation' : {},
- 'network-address' : {'extra_sources': ['mock-resolver.c'], 'suite': ['flaky']},
+ 'network-address' : {'extra_sources': ['mock-resolver.c']},
'network-monitor' : {},
'network-monitor-race' : {},
'permission' : {},
@@ -67,7 +67,7 @@ gio_tests = {
'sleepy-stream' : {},
'socket' : {},
'socket-listener' : {},
- 'socket-service' : {},
+ 'socket-service' : { 'suite': ['flaky'] },
'srvtarget' : {},
'task' : {},
'vfs' : {},
@@ -140,11 +140,16 @@ if host_machine.system() != 'windows'
'slow-connect-preload.c',
name_prefix : '',
dependencies: cc.find_library('dl'),
+ install_dir : installed_tests_execdir,
+ install: installed_tests_enabled,
)
],
'env' : {
'LD_PRELOAD': '@0@/slow-connect-preload.so'.format(meson.current_build_dir())
},
+ 'installed_tests_env' : {
+ 'LD_PRELOAD': '@0@/slow-connect-preload.so'.format(installed_tests_execdir),
+ },
'suite': ['flaky'],
},
'gschema-compile' : {'install' : false},
@@ -428,6 +433,7 @@ if installed_tests_enabled
'appinfo-test-static.desktop',
'file.c',
'org.gtk.test.dbusappinfo.desktop',
+ 'test1.overlay',
install_dir : installed_tests_execdir,
)
install_subdir('x-content', install_dir : installed_tests_execdir)
@@ -592,11 +598,21 @@ foreach test_name, extra_args : gio_tests
source = extra_args.get('source', test_name + '.c')
extra_sources = extra_args.get('extra_sources', [])
install = installed_tests_enabled and extra_args.get('install', true)
+ installed_tests_env = extra_args.get('installed_tests_env', {})
if install
test_conf = configuration_data()
test_conf.set('installed_tests_dir', installed_tests_execdir)
test_conf.set('program', test_name)
+ test_env_override = ''
+ if installed_tests_env != {}
+ envs = []
+ foreach var, value : installed_tests_env
+ envs += '@0@=@1@'.format(var, value)
+ endforeach
+ test_env_override = '@0@ @1@ '.format(env_program.path(), ' '.join(envs))
+ endif
+ test_conf.set('env', test_env_override)
configure_file(
input: installed_tests_template_tap,
output: test_name + '.test',