summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schuh <andreas.schuh.84@gmail.com>2014-05-01 19:58:25 +0100
committerAndreas Schuh <andreas.schuh.84@gmail.com>2014-05-01 19:58:25 +0100
commit31f0e290d632d755034d6d2d2c29d3ec7be6b3f0 (patch)
treee3d1de5caa1167efb00297a599e412f0ad5a57d6 /CMakeLists.txt
parent3c30390ac4dcd09f570a4cc053686be4bc957708 (diff)
downloadgflags-31f0e290d632d755034d6d2d2c29d3ec7be6b3f0.tar.gz
gflags-31f0e290d632d755034d6d2d2c29d3ec7be6b3f0.tar.bz2
gflags-31f0e290d632d755034d6d2d2c29d3ec7be6b3f0.zip
Use LIB_INSTALL_DIR to initialize LIBRARY_INSTALL_DIR.
In particular the Fedora package maintainers pass LIB_INSTALL_DIR instead of LIBRARY_INSTALL_DIR.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee81c1b..a4d0f07 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,11 +280,14 @@ if (OS_WINDOWS)
set (CONFIG_INSTALL_DIR CMake)
else ()
set (RUNTIME_INSTALL_DIR bin)
- # The LIB_SUFFIX variable is used by the Fedora package maintainers.
- # Also package maintainers of other distribution packages need to be able
- # to specify the name of the library directory.
- set (LIBRARY_INSTALL_DIR lib${LIB_SUFFIX}
- CACHE STRING "Directory name for installed libraries, e.g., \"lib64\""
+ # The LIB_INSTALL_DIR and LIB_SUFFIX variables are used by the Fedora
+ # package maintainers. Also package maintainers of other distribution
+ # packages need to be able to specify the name of the library directory.
+ if (NOT LIB_INSTALL_DIR)
+ set (LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
+ endif ()
+ set (LIBRARY_INSTALL_DIR "${LIB_INSTALL_DIR}"
+ CACHE PATH "Directory of installed libraries, e.g., \"lib64\""
)
mark_as_advanced (LIBRARY_INSTALL_DIR)
set (INCLUDE_INSTALL_DIR include)